Holochain Forum

Using holochain on OSX Big Sur (without nix)

Until we find a fix for using holonix on Big Sur (see Holonix fails on latest MacOS: Big Sur)

…those of us on Big Sur who are relentlessly trying to develop HC apps have a few options:

  1. Use Docker
  2. Use a vitualization tool like Multipass ( see my post within Is there a hello world or simple chat app for RSM? )
  3. Go straight to raw rustup/cargo etc on the mac – ie no nix, and no linux-within-mac

Any of these should be considered workarounds until holonix is fixed, as that is the blessed path.

Having said that, after trying all three, I’ve found #3 to be the simplest and fastest.

Here’s what I did in a nutshell:

curl https://sh.rustup.rs -sSf | sh
rustup update            # probably not needed
rustup install stable
rustup default stable

git clone https://github.com/holochain/holochain
cd holochain
cargo install --path crates/holochain
cargo install --path crates/dna_util
cargo install --path crates/hc
cargo install --git https://github.com/holochain/lair
yes | holochain -i

See also this post from @pqcdev if you’re still having trouble, there are few additional tips in there: Nix on MacOS Catalina

6 Likes

Awesome.

I copied your suggested commands and entered them all at once in my terminal. Everything seems to have worked except for the lair.

➜  holochain git:(develop) holochain -i
Mar 19 20:43:31.967 ERROR lair_keystore_client: error=IpcClientConnectError("/Users/moritzbierling/Library/Application Support/host.Holo.Lair/socket", Os { code: 61, kind: ConnectionRefused, message: "Connection refused" }) file="/Users/moritzbierling/.cargo/registry/src/github.com-1ecc6299db9ec823/lair_keystore_client-0.0.1-alpha.11/src/lib.rs" line=42

###HOLOCHAIN_SETUP###
###HOLOCHAIN_SETUP_END###
Conductor ready.

Thanks @bierlingm I see errors like this too, but everything seems to work ok… does the holochain app in question work for you?

1 Like

Haven’t tried running any app with it yet. Got any you’re running that I could try out?

Sure, this one is simple and worked for me:

3 Likes

Hey @harlan!

I would just like to express my gratitude for this really really helpful post! I also checked other related posts on challenges in working with macOS so for all those who have been doing something about this, thank you so much!

I’m running macOS Catalina (10.15.7) but encountered issue with running Holonix as well.
But what is IMPORTANT though is that this instruction WORKS and has saved me so much time and I can now get back to playing with holochain! Highly recommended for others who are struggling with macOS right now!

That’s all and I hope you are having a great week!

3 Likes

Very nice! I’ve been hacking too hard on the docker angle. Compiling directly sounds so nice if not really deterministic.

you could always get elemental-chat going!


Great to see you here @dukejones!

Yes, I got elemental chat working too, though at the time a month or so ago I had to lock the server to a specific commit. YMMV.

1 Like

Hi, thanks, it seems to always get stuck withthe following error. holochain/crates/dna_util` is not a directory. --path must point to a directory containing a Cargo.toml file. Was it suppose to create every file and directory automatically or do we do something manually? Thanks in advance