Holochain Forum

Setup: “nix-shell https://holochain.love” issues

After launching the “nix-shell https://holochain.love” command (“Development Tools Installations” webpage), it “hung” a couple of times (no new text appearing), then picked up again.

I launched nix-shell 4 hours ago. Okay, they say it will take “some time” but that’s a relative notion! I will continue to let it run but please tell me if there’s something I should do about this. (Win10, HP Workstation with 8GB RAM.)

These are the last lines that popped up so far:

copying path ‘/nix/store/wkg4bpdhak3mwg0cm1b8rihgigra5k2w-libSM-1.2.3-dev’ from ‘ttps://cache.nixos.org’…
copying path ‘/nix/store/hgyp9npj7n4riiknkb6djf9m42kq70zn-aeson-1.4.2.0-doc’ from ‘ttps://cache.nixos.org’…
copying path ‘/nix/store/849wgdkw1w03mj3x0y43al00w3a92mjk-lens-4.17-doc’ from ‘ttps://cache.nixos.org’…

(Sorry I had to remove the ‘h’ from ‘https’ because the links created were not accepted by the forum interface! Any other way to prevent automatic creation of hyperlinks from a URL?)

I will share my findings as I go along, installing and using Holochain (in a VM under Windows). I hope that this is useful. If you come across useful material aside from the official Holochain installation instructions, please feel free to share under the getting started threads.

That is too long. It could be related to internet speed, disk space, etc? There could be other factors impacting the install. If it’s taking too long, I would simply restart the process.

Okay thanks, I exited CMD, then started nix-shell again. It went smoothly this time but it finished with an error: “cannot write: no space left on device”.

(My HD has 600GB free. What is it looking at? I remember a warning after vagrant up succeeded, but this might be irrelevant: shared folders might malfunction because of guest additions and virtualbox versions discrepancy.)

Here are some of the last lines:

tar: rust-nightly-x86_64-unknown-linux-gnu/rustc/lib/rustlib/etc/lldb_rust_formatters.py: Cannot write: No space left on device
tar: rust-nightly-x86_64-unknown-linux-gnu/llvm-tools-preview/lib/rustlib/x86_64-unknown-linux-gnu/bin/llvm-objcopy: Cannot write: No space left on device
tar: rust-nightly-x86_64-unknown-linux-gnu/clippy-preview/bin/cargo-clippy: Cannot write: No space left on device
tar: Exiting with failure status due to previous errors
do not know how to unpack source archive /nix/store/qf8ks81hjncyrycsqjj3vqlhjb8pp19z-rust-nightly-x86_64-unknown-linux-gnu.tar.xz
builder for ‘/nix/store/j8j2vnskqhd8x8sc46qnl8x1bqdk7nwd-rust.drv’ failed with exit code 1
note: build failure may have been caused by lack of free disk space
cannot build derivation ‘/nix/store/sqll2fajnq18cjxcjnxf1bgyrjlspn4i-rust-1.38.0-nightly-2019-07-13-69656fa4c.drv’: 1 dependencies couldn’t be built
error: build of ‘/nix/store/sqll2fajnq18cjxcjnxf1bgyrjlspn4i-rust-1.38.0-nightly-2019-07-13-69656fa4c.drv’ failed

[vagrant@nixos:/vagrant]$

Forgot to answer that one, about the previous issue when it was hanging:

Just tested it: download 13Mbps, upload 7Mbps, that’s weak!
Using a wifi connection on a workstation, no LAN available on this floor at home.
(As a comparison: laptop near modem has 42Mbps download speed.)

Doesn’t look like this could be the cause for the current issue, though (disk space error, see my previous message).

Just checking when you say cmd are you using powershell or the regular windows cmd?

@sachaweb based on your other post it looks like you were able to resolve this and were able to install Holochain.

Hi @freesig, by CMD I mean the regular Windows command line interface. Should I be using Powershell instead??

@sachaweb it’s worth a try for sure. I’m actually thinking that the issue is the size of the VM’s allocated disk space. Which is set in the Vagrant file.
This is how to set that.
The vagrant file is the one you downloaded with wget.

Okay things have changed: there are new instructions on the HC installation instructions page and with these, I didn’t run into the disk space issue (this time in Powershell as you suggested, @freesig).

So I probably won’t have to fiddle with the Vagrant file, thankfully…

The instructions I’m pretty sure were not present or different yesterday are:

cd /vagrant
nix-env -f https://holochain.love -iA holochain.holochain holochain.hc

Thanks @freesig

1 Like

I have run into similar issues, it hangs when it gets to the first copy statement:

copying path ‘/nix/store/d4c9yp4w96g45fivnljg32zjrvdfp10h-ghc-8.6.4’ from ‘https://cache.nixos.org’…

How long should this take?

I only have 4GB Ram so I thought it might be a bit slower but it has been over 4 hours now!

On the Getting Started page it doesn’t have the line you mentioned. It simply states:

nix-shell https://holochain.love

So should I just restart it and use nix-env -f https://holochain.love -iA holochain.holochain holochain.hc instead?

I was hoping to get up the latest version before the dev camp tonight since I am on v17, after all the posts I was seeing about upgrading, I didn’t want to lose time with all the upgrade issues, but now due to devcamp I am forced to. I presume they will be using the latest version?

Any help would be really appreciated.

Many thanks,
David. :slight_smile: :space_invader:

Ok I tried:

nix-env -f https://holochain.love -iA holochain.holochain holochain.hc

It got further, and HC seems to be working but Rust was not installed as you can see below. I tried running the rust command “rustup https://rustup.rs/” as suggested but it doesn’t recognise the rustup command. I’m running this in a PowerShell window on my Windows 10 Laptop so I can’t simply download Rust and install it like I did for Windows. So what do I do now?

I thought the whole point of NIX was to make life easier? So it would all be working automatically? So far is has taken a lot more time and hassle and it still is not working… :frowning: But I hope it will all work out in the end… :slight_smile:

[vagrant@nixos:/vagrant]$ hc --version
hc 0.0.28-alpha1

[vagrant@nixos:/vagrant]$ holochain --version
holochain 0.0.28-alpha1

[vagrant@nixos:/vagrant]$ hc init my_first_app
Created new Holochain project at: “my_first_app”

[vagrant@nixos:/vagrant]$ dir
my_first_app Vagrantfile

[vagrant@nixos:/vagrant]$ cd my_first_app

[vagrant@nixos:/vagrant/my_first_app]$ hc generate zomes/my_zome
This command requires the cargo command, which is part of the Rust toolchain.
Generating a Rust based Zome depends on having Rust installed.
As a first step, get Rust installed by using rustup https://rustup.rs/.
Holochain requires you use the nightly-2019-07-14 toolchain.
With Rust already installed switch to it by running the following commands:
$ rustup toolchain install nightly-2019-07-14
$ rustup default nightly-2019-07-14
Having taken those steps, retry this command.

[vagrant@nixos:/vagrant/my_first_app]$ rustup https://rustup.rs/
rustup: command not found

Hey @dellams can you try to get WLS2? If so, please use it and see if you can achieve the same end. https://docs.microsoft.com/en-us/windows/wsl/wsl2-install
A few of our core devs have tried it.


1 Like

Thanks for getting back to me. :slight_smile:

I am giving WSL ago now, but it looks my windows build is not high enough for WSL2 but I will give that ago anyway, if not I will still try WSL1 if that still works?

Regarding makeWrapper, how do I use that? What is the syntax, etc? Thanks :slight_smile:

@dellams makeWrapper is something that needs to be rolled into holonix itself, basically it sets up a mini nix shell (that would contain cargo) for hc when it is installed by nix-env

WSL1 can be used but there is some extra config see the discussion here https://docs.holochain.love/docs/install/

Ok thanks. :slight_smile:

I got Linux Ubuntu v18.04 LTS working in Windows using WLS but now I got new errors.

I tried to upgrade to WSL2 but my version of Windows doesn’t support it so it’s looking like I will need to dual boot a full Ubuntu install unless you can see what is causing the errors above?

Is this related to the /etc/nix/nix.conf file you mention that needs editing?

If so how do I edit it from my bash terminal? Sorry I have very little experience with Linux coming from a Windows and .NET background… :slight_smile:

@dellams so! i just release holonix v0.0.31 which includes the makeWrapper which should mean that hc includes all its dependencies when installed by nix-env

re-installing it like

nix-env -f https://holochain.love -iA holochain.hc

should be enough to take effect

i haven’t seen it working in WSL 1 myself (i managed to get WSL 2 working), but my understanding is yes you do need to set the config for it to work there

see the discussion here: I'm spinning up some docs for holonix, feedback welcome :)