Holochain Forum

WANTED: Devs with macOS Catalina or Windows 10 to test an easier install process

I’ve heard some promising news in the world of Nix:

  • The Nix package manager can now be installed on macOS Catalina.
  • The Windows 10 May Update (v2004) now contains WSL2, which can run Nix without problem.

I’m looking for people who have the above operating systems and have had struggles with our installation procedure and are eager to try again. If this is you, here’s how to test:

Catalina users

Follow the installation procedure, but instead of typing the command curl https://nixos.org/nix/install | sh type this command:

sh <(curl https://nixos.org/nix/install) --darwin-use-unencrypted-nix-store-volume

This installs Nix with the Catalina workaround that the Nix developers have created. Then follow along with the rest of the installation instructions.

Windows 10 users

Before you start the installation procedure:

  1. Make sure that you’re updated to the May 2020 Update. Go to System → About, and look at the version number; it should be 2004. If it isn’t, go to Settings → Update & Security → Windows Update. Install the ‘Feature update to Windows 10, version 2004’.
  2. Install Ubuntu from the Windows Store.

After that, you can follow the installation procedure for macOS and Linux.

Let us know how it went!

Once you’ve done this, come back to this thread and let me know if it went smoothly. I’m eager to simplify the installation instructions so new devs can get started more quickly.

Are you on Windows 7?

If you’re on an older version of Windows, do you think it would be a good or a bad idea for the installation instructions to recommend using Linux via a virtual machine? I know it’s not the ideal situation, but it might make for a more successful first-time dev experience while Windows support is still lagging behind macOS and Linux.

1 Like

Hey, I tried it on Mac, worked all good, no problems :slight_smile:
I also have a Win10, but didn’t get to trying it on that yet… might do tomorrow.

2 Likes

Smooth for Windows10 WSL1
Tested 6/11/2020

Not sure if this helps.

Everything went smooth. I followed steps provided here in NathanBijnens blog, for full disclosure I just followed steps until WSL1 and did not do WSL2 following Windows SubSystem for Linux (WSL) installation steps


Assumption behind suggesting Smooth, since I was able to successfully install HoloChain (success) after installing Nix (success) in order to install HoloChain Photos hAPP (failed) thread asking for help around holochain photos code read


Thanks to the both of you @derjogi and @Aryabhatta !

@derjogi just to confirm, you have macOS Catalina 10.16, right?

@Aryabhatta I’d never heard about this workround before; it’s good stuff! Microsoft offers downloadable VM images of Windows 10 pre-v2004 (still contains WSL1) so maybe I’ll try that out and see what could be causing that error.

@pauldaoust I got macOS Catalina 10.15.5, 10.16 isn’t released yet and won’t be Catalina.

I installed holochain, but didn’t try running any hApps though, in case that matters.

Oh sorry, that’s what happens when you do a quick web search and read the summary card too quickly. I guess ‘sixteenth version’ would mean .15 if the first version was .0, right? :sweat_smile: :man_facepalming:

Thanks for setting me straight!

I did install nix in a windows machine with wsl2 some time ago, it worked but the mayor issue was having RLS working.
I wrote some steps on how to make it work, RLS works but not the way it should in a Linux machine.
Here are the steps I followed:

@sdelvalle57 thanks again for going beyond what was requested and giving tips for RLS!