Setup: “nix-shell” issues

Hey @dellams can you try to get WLS2? If so, please use it and see if you can achieve the same end.
A few of our core devs have tried it.

1 Like

Thanks for getting back to me. :slight_smile:

I am giving WSL ago now, but it looks my windows build is not high enough for WSL2 but I will give that ago anyway, if not I will still try WSL1 if that still works?

Regarding makeWrapper, how do I use that? What is the syntax, etc? Thanks :slight_smile:

@dellams makeWrapper is something that needs to be rolled into holonix itself, basically it sets up a mini nix shell (that would contain cargo) for hc when it is installed by nix-env

WSL1 can be used but there is some extra config see the discussion here

Ok thanks. :slight_smile:

I got Linux Ubuntu v18.04 LTS working in Windows using WLS but now I got new errors.

I tried to upgrade to WSL2 but my version of Windows doesn’t support it so it’s looking like I will need to dual boot a full Ubuntu install unless you can see what is causing the errors above?

Is this related to the /etc/nix/nix.conf file you mention that needs editing?

If so how do I edit it from my bash terminal? Sorry I have very little experience with Linux coming from a Windows and .NET background… :slight_smile:

1 Like

@dellams so! i just release holonix v0.0.31 which includes the makeWrapper which should mean that hc includes all its dependencies when installed by nix-env

re-installing it like

nix-env -f -iA holochain.hc

should be enough to take effect

i haven’t seen it working in WSL 1 myself (i managed to get WSL 2 working), but my understanding is yes you do need to set the config for it to work there

see the discussion here: I'm spinning up some docs for holonix, feedback welcome :)

Still have the “Cannot write: No space left on device” problem. I am tying out Holochain on Fedora running on a Qubes-OS computer, this time :slight_smile: I do see that this has very low priority and maybe I could try build from source, need to get Holochain running on a Raspberry Pi also, so learning to build is necessary!

@tggraner obvious question but is it out of space?

1 Like

No, I allocated >32GB. I think I need to take a deep dive into the holochain system to figure out how to make it work on Qubes OS, in a way that take advantage of Qubes OS security features. This will take awhile… :slight_smile:

@tggraner any luck with Qubes? i’ve never tried it myself :sweat_smile:

No, but the problem might be using Debian 10 or Fedora 29 when developing Holochain applications not Qubes or Xen (the hypervisor). Does anyone use anything else than Mac OS or Ubuntu?

@tggraner i use ubuntu and nixos and mac os (pre catalina) and rarely windows WSL2

there is also a dockerbox in holonix that demonstrates basic debian support (it installs)

i know at least one person on the networking team uses debian regularly

1 Like

I am installing holochain for the first time using vagrant.

When I get to the step

I get an issue:
unpacking ‘’…
tar: Skipping to next header

gzip: stdin: invalid compressed data–format violated
tar: Child returned status 1
tar: Error is not recoverable: exiting now
error: program ‘tar’ failed with exit code 2
(use ‘–show-trace’ to show detailed location information)

I am also finding that vagrant up fails periodically but has run successfully. The error

nixos-rebuild switch

Stdout from the command:

Stderr from the command:

nix-build: symbol lookup error: /nix/store/kwjql4pmjjm4ya198m2hzw516mdlyqsn-aws-sdk-cpp-1.3.22/lib/ undefined symbol: ZNK3Aws2S38S3Client42PutBucketAnalyticsConfigurationAsyncHelperERKNS0_5Model38PutBucketAnalyticsConfigurationRequestERKSt8functionIFvPKS1_S5_RKNS_5Utils7OutcomeINS_8NoResultENS_6Client8AWSErrorINS0_8S3ErrorsEEEEERKSt10shared_ptrIKNSC

Is there a docker-compose based install? My enthusiasm for Holochain is waning. I do all my prototyping on docker and have no great fondness for VirtualBox.

@douglasdzone1 several options including docker are listed here -

we do all our CI testing on docker so you can see the circle ci config for more examples and the docker/* folder for dockerfiles

Hey guys I’m just jumping back into the hc community after being working flat out building a new prototype to secure funding, which I’m happy to say is in its way at long last! :blush:

Were the windows issues resolved now? I saw on a recent dev pulse that a new update to windows included WSL 2 so the issues with NIX should now be resolved? :blush:

1 Like

Should indeed work with WSL2! I’ve asked a couple people to test it out for me, and they’ve had perfect success.

1 Like

Yes I can confirm this, I am all setup now on both Windows and Linux ready for devcamp… be good to see you all again… :slight_smile:

I am currently making good progress on the .NET HDK and I am about to reach out to the community for some help with this… I have found a way to compile .NET code to WASM and I am also using the Wasmer lib to call into the HC Core API in the Conductor WASM.

I just created a thread for this here:

Would really appreciate your input bro, because I know you were giving me some good advice before and you also have a .NET background… thanks :slight_smile:


Is there a way I can get my hc (zomes, etc) out of the Nix shell and into Windows file system? I need to be able to access this somehow? Hopefully there is a way? :slight_smile:


Figured it out! :slight_smile:

You can map “\wsl$” to a network drive to get access to the virtual Linux installs you have. For example to get to my HOME dir in my virtual Ubuntu it is:


You can even get access to the NIX Shell folders including the files like this:


The hash will be different depending on which version of you have downloaded.

Hope this is of help to people… :slight_smile: