Holochain Forum

Happ-build-tutorial

Hi there

When I follow:

and run the command npm test, it ends with this message:

[tryorama] error: Test error: 'Error: Timed out in 30000ms: zome_call_invocation\n' +
  '    at Timeout.<anonymous> (/home/admin/happ-build-tutorial/tests/node_modules/@holochain/conductor-api/src/websocket/common.ts:16:14)\n' +
  '    at listOnTimeout (internal/timers.js:554:17)\n' +
  '    at processTimers (internal/timers.js:497:7)'
not ok 1 Test threw an exception. See output for details.
  ---
    operator: fail
    at: <anonymous> (/home/admin/happ-build-tutorial/tests/node_modules/@holochain/tryorama/src/middleware.ts:137:13)
    stack: |-
      Error: Test threw an exception. See output for details.
          at Test.assert [as _assert] (/home/admin/happ-build-tutorial/tests/node_modules/tape/lib/test.js:304:54)
          at Test.bound [as _assert] (/home/admin/happ-build-tutorial/tests/node_modules/tape/lib/test.js:91:32)
          at Test.fail (/home/admin/happ-build-tutorial/tests/node_modules/tape/lib/test.js:398:10)
          at Test.bound [as fail] (/home/admin/happ-build-tutorial/tests/node_modules/tape/lib/test.js:91:32)
          at /home/admin/happ-build-tutorial/tests/node_modules/@holochain/tryorama/src/middleware.ts:137:13

What can I do to make it run?

Have you been to the Holochain Gym yet?

That’s probably a good place to start :wink:

…also there’s

I could take a look today and see why. I recently had a hand in some edits to the repository.

@Ben can you check this issue to see if matches yours?

does yours show this message at all?

ZomeError(ZomeNotFound(“Zome ‘numbers’ not found”))’

I’ve just mentioned to the person who raised that issue that I’ve just gone through the happ-build-tutorial myself again, from fresh start, and found the tests passing. We need to know what’s different that you did than what I did. For starters, I’m on a mac, but I doubt that it’s an operating system thing since we’re using nix-shell.

Thanks for answer guys.

I also checked Holochain Gym, but I’m afraid the basic exercise are beyond my skills…
I’m trying to have any demo of Holochain app running to make it the technology used for my next project…(still on research)
But so far all my attempted of install a happ ends with a failed…Not easy to get a demo run

Here are some of my attempted posted on the forum:

rad-tools-phase-2/6586
hc-happ-scaffold/6587
happ-build-tutorial/6588

Not mentioned above, I also tried holo-proto (go), elementalChat…but all are also deprecated…

Can anyone recommend me a easy step by step solution to have any kind of app running on Holo for I can use as demo?

Connoropolous, I looks indeed same issue:

thread 'holochain-tokio-thread' panicked at 'TODO: ZomeError(ZomeNotFound("Zome \'numbers\' not found"))', /tmp/nix-build-holochain.drv-0/source/crates/holochain/src/core/ribosome.rs:339:14

I try again and update Test failing · Issue #17 · holochain/happ-build-tutorial · GitHub if I still got the same issue

I retried the tutorial (2 different ways):
. git clone and straight to step 5
. git clone and all the steps
both end again with the same message…when I run npm test

thread 'holochain-tokio-thread' panicked at 'TODO: ZomeError(ZomeNotFound("Zome \'numbers\' not found"))', /tmp/nix-build-holochain.drv-0/source/crates/holochain/src/core/ribosome.rs:339:14

Just for information on step 3 :

hc dna pack dna-folder

Add issue with the path…it expected the folder target in the folder-dna…so simply copy the target folder to dna-folder solved the issue…

Ok yeah since multiple people have the same issue report. I will try and figure out why it didn’t do that for me.

Question tho, just to confirm, you were in the nix-shell?

1 Like

Hey @Ben we’ve figured it out we think.

You have two options, run these two commands:
hc dna pack workdir/dna
and
hc app pack workdir/happ
and then rerun your tests.

Or, you can pull the latest commit from develop branch of the repository which has the included built files fixed.

yes I was in nix-shell.
run the two hc commands on the folder mentioned above ended again with same message…

So I re-tried from scratch:

git clone holochain/happ-build-tutorial.git
cd happ-build-tutorial
nix-shell
rm -fr .git
cd tests && npm install
npm test

This time the test passed !

Then I run the happ in sandbox and it successfully connected to a running holochain…But it is just with the built files…I will now try again from step 1 to step 5

Thanks

Is there a similar tools like RAD-Tools-phase2 or scaffold or holochain-proto (Go) which I can use?

hey, I’m trying to learn how to build a smart contract app using holochain. But I’m a bit lost as I’ve only found tutorials for Rust with blockchain based tech. Any guidance or if anyone is interested in partnering up, that’d be highly appreciated.
Cheers