Holochain Forum

Can´t install NixOS on Windows with VirtualBox

I wanted to install NixOS on Windows via VirtualBox. !
But when I run the NixOS on VirtualBox it always stops at “NixOS Step 1” “running udev…” that´s it!
I don´t know what´s wrong. I hope somebody can help me?
Best regards,

Hi @newprometheus sorry you’re having issues with virtual box.
It could be that the virtual box is not big enough. How long did it stay stuck for? Also are you on fast internet?
Another option would be to look into WSL2: Native NixOS for Windows?

Hi @freesig thank you very much for your help. I could manage it now to install NixOS on an external HDD. So when I check the NixOS version I got 2.3. That looks fine for me. But when I try to install nix-shell, I got an error message “lack of free disk space”. Maybe I made a mistake of disk participation? My external HDD has 120 GB. I made a participation of 1,7GB for the iso file and than - after rebooting and installing NixOS, I tried to make a new particpation of the unallocated disk (110 GB). But I guess there went something wrong… :frowning_face:

Now, I could run the virtual box and the installer of NixOS runs properly. But it starts always automatically with the nixos-account…

How can I swith to the root-account? If I write “su root”, the system asks about the Password and I got “Authentication failure”. But I never set a password?!

Somebody has an idea, how to fix that?
Thank you very much. I appreciate any hint.

Ha!!! I could do it!!! I figured it out how to install Holochain on VirtualBox with Vagrant. Everything works now properly and I will start to write my_first_app!

I´m looking forward to see what´s coming next! :-):smile:

1 Like

hi @newprometheus ,
Can you please post how you resolved this? I’m trying to set up holonix on VirtualBox (Ubuntu 64-bit) on Mac big sur.
I configured a 60gb (Holochain requires 30) VDI drive, and it’s failing because of “not enough space” when it tries to use 30 GB disk space.
Thank you.