Holochain Forum

Passphrase error in holochain project in a docker image

Hi everybody, I created a holochain project docker image, the problem is when I try to run the conductor, I previously created a .key file with “hc keygen -np test1.key”, with the “-n” parameter the nix is not going to ask me for a passphrase.

This is the docker-compose.yml

services:
sim2h_server:
image: ‘holochain/holochain-rust:sim2h_server.master’
ports:
- 9000:9000
command: sim2h_server
conductor:
image: ‘monashtem’
ports:
- 3400:3400
command: nix-shell happ --command “cd happ && holochain -c conductor-config.toml”

I am able to create the docker image, when I am inside the holachain docker image, I run the nix shell and try to run the conductor but the nix ask me for the passphrase, even thought I created the .key file with the “-n” parameter.

image

I already created another .key file but with the passphrase. I tried to use that passphrase but I got what is invalid… Help please =(

There was a change of key format at one point. You may have to regenerate your keys for the latest version to work.

Hello @zippy, how can I do that?
I already created the key file several times and the nix still ask me for the passphrase