Holochain Forum

Is everything broken in holochain land - Hello World fails even with example code?

Are things broken in Holo-land with tutorials ? At least on Macs ? The tutorials are supposed to be fixed, but neither the tutorial code from the “Check your code” box, nor the code you would have if you followed the instructions (they are quite different) actually work. This seems to be a persistent problem, maybe you could post a complete set of files for this stage of the Hello-World tutorial as I’ve been stuck at this point now for three weeks, and its hard to progress to actually writing apps, when the tutorials don’t work at all - especially this key one of getting things to talk to each other.

Bugs have been posted, e.g on github at holochain/docs-pages/issues/169 but they’ve been closed without actually getting fixed.

Hi @mitra42
I put the working version code of Art_Game from tutorial in my github repository. try it.

1 Like

Hi @mitra42 I really hope everything isn’t broken, I’m putting a lot of work into preventing that.

I really appreciate your feedback this helps me improve things.
I think the issue here is not that things are broken in this version of the tutorials it’s more that the tutorials have changed to keep up with holochain / fix issues. So there’s differences between the version you were following up to this point and v0.3.0

I’m trying to figure out a good way to handle these transitions in a smoother way.

The “Check you code” sections are generated from the steps so they should be accurate (please let me know if this is not the case). I think what has happened is the steps have changed.
I replied to that issue and perhaps it would be useful to have the full set of files accessible as a “solution” at the end of each tutorial. That way you can always check. Would that help? I’d love for this to be as smooth as possible for you and don’t want anyone to be getting stuck in the tutorials. The challenge is holochain itself and the build tools are rapidly changing under my feet.
Thanks again for bringing these issue to light, let me know if there’s anything else I can do to make things smoother.

2 Likes

Yes - fully understand that things are changing, and after tutorial revision the step-by-step code might not match the currently wanted code, which is why I switched to use “Check your Code” but that didn’t work either - I posted the bugs to github.

Posting complete set of files to a git repo would be great - I’ve literally been stuck on this tutorial for 3 weeks now, its taken over a month, and I’m still not through a set of tutorials that I should have been able to complete in 2 evenings because of all the bugs in the tutorials. That’s a month of not even starting to try and develop anything.

At the moment there is AFAIK no working version of Hello-Me tutorial, neither the step by step (which might be out of date) not “Check your Code” which shouldn’t be actually work - and that’s third time of report bug, wait for fix, retry, hit new bug, repeat in Hello-Me alone.

As both an investor and friend of many of the team I figured I should stick around and give feedback, but if I was a regular developer I’d have walked by now, since broken (self inconsistent) tutorials are often an indication that the underlying system is really broken.

2 Likes

I share your frustration. I had those fixes done a few days after you raised them but was unable to release them because I needed to wait for changes to be released in holochain itself that fixed some of the bugs.
I’ve also tried to address these concerns by creating a system where every single piece of the code in the tutorials is compiled and tested.
I will get these files added to the end of the tutorials to try and avoid this problem.

I think if you update the .hcbuild file as stated in the issue it really should be working as I’ve tried it multiple times on this computer and it passes all our CI tests.

I’m also working with the core team to try and avoid getting blocked by a release again. I truly do care about this project and it saddens me to hear your having such a hard experience. I hope we can work together to make it better for you and others that follow.

3 Likes

@mitra42 try cloning my repo of holo.txt, a simple notes editing app that differ only minimally from the tutorials. That should get you started.

I would also like to provide an alternate story of my experience with the tutorials.

I ran through all core concept tutorials in mid december and didn’t have any problems.

:slight_smile: That wasn’t much of a story. But that was it, it took like two or three hours to run through all the tutorials. Possibly there were some small details that wasn’t 100% documented. But overall, I found the guidance really easy to follow. And I’m not a Rust developer or anything.

Thanks @freesig, @lucksus, @pauldaoust for all the hard work you are putting in to get this thing off the ground!

4 Likes

I have added the solutions to the tutorials. They are at the bottom of each tutorial and under the corresponding branch on this repo.

1 Like

Thanks - will give that a go.

1 Like

Same bug - using JUST your code -(on a mac) error posted to https://github.com/holochain/docs-pages/issues/179

FWIW, I ran through the tutorials in the last week of December— getting nix working on the latest OSX was painful, but after that everything worked very smoothly for me.

1 Like

So maybe the problem is nix - but nix was working fine until recently (and I haven’t upgraded OS) so sounds like miss-match somewhere, (which is hilarious given the selling point of nix being cross-platform …) any idea how to solve this.

What OS are you running?

MacOS 10.14.6

1 Like

I’m running Mac OS 10.14.6 as well, and at least the core functionality - compile / run was running before the holidays, maybe there was an update in holo or something in that period that caused it to play badly with the nix ?

I’ve updated nix, and nothing changed @harlan - you said getting nix working on latest OSX was painful, can you explain what you had to do - or was it just to do with OSX10.15 ? (I’m on 10.14.6) and dead in the water for a month now :frowning:

@mitra42 this is what solved my issue on Catalina — Nix on MacOS Catalina

Unrelated to your issue AFAICT.

Looks like noone is interested in this issue, completely stuck with doing any dev on holochain since “hc” doesn’t work :frowning:

Maybe join the devcamp in progress? There are live support sessions there.

yes - joined it, haven’t been able to get on any of the live sessions yet, and not sure how to, or how to bring this issue with a broken dev environment to it. The call announcement I got refers to a specific topic " Entry Design and a demo of Passthrough DNA." which there’s really no point in me participating in since the basic environment in which I’d build something isn’t working (even after deleting and reinstalling nix)

Hi @mitra42, I just found this github issue.

Did you manage to solve the issue and are there other people with the same problem?