Introducing the Holochain Community Currency experiment

We are introducing a holochain community mutual-credit experiment. This is an experiment combining two popular mechanisms around the holochain community:

With this we want to achieve 3 goals:

  • Experiment with these patterns and see what works and what doesn’t, at the social layer and also at the security/technical layer.
  • Arrive to an MVP like implementation of all modules. We have implemented the code in modular fashion, having the zomes available to download as git submodules and the UI code as NPM packages (documentation still to come).
  • Engage the holochain community in a social game, and have fun!

Parameters of the game:

  • Number of necessary vouches to enter the network: 2
  • Negative credit limit: -100 credits

How to play the game!

Only working in Linux and MacOS

  1. (Optional): If you already had holoscape installed, delete the .config/holoscape-default folder in the home directory.

  2. Download holoscape v0.0.9: Pick linux or MacOs, and extract it.

  3. Download the bundle:

  4. Boot up the holoscape with ./

  5. Fast-forward with okey.

  6. When you arrive to the main holoscape page, click on the holoscape icon on the top bar and click “install from file” and select the bundle.toml

  7. IMPORTANT: select the admin interface checkbox, and click install

  8. Ask for someone to vouch for you!

Please post here any issues or suggestions from this experiment.

People inside the list that you can vouch for you: @guillemcordoba, @hedayat, @sidsthalekar, @nphias.


Ping @mwl – thought you would be interested in this! The guts of a LETS-style mutual credit Holochain app!

(for context all: @mwl is the creator of LETS)

1 Like

Trying to follow instructions, on Ubuntu 18.04 with gnome shell, running script gives a coredump. Per Jakob’s suggestion, I tried as root using --no-sandbox and running the executable directly from the linux-x64 directory, and Holoscape runs successfully…

[Holoscape-linux-x64]$ sudo ./Holoscape --no-sandbox

I see a Holospace menu outside the window up in my menu bar, but I do not see “Install from file…” I am thinking that would be because I said --no-sandbox, but the executable will not let me run as root unless I use --no-sandbox, and it coredumps if I try to run as normal user.

Any suggesstions? Gratitude.

Thanks Paul - I would have missed this without your prompt.

It’s very exciting to see these “guts” on display, and will be more so to see them as they develop.

The other parts of the package - the muscle, bone and skin (in the game) - will follow very soon, I am sure.


This is awesome!

I’ve got one vouch so far, who wants to give me another one?

My agent name is ‘bierlingm’.

Once I’m in, I’ll happily vouch for others!

Did you mean to write holoscape v0.0.9? Because that’s what you linked to. :smiley:

1 Like

UPDATE: just to let everyone know, we are experiencing some issues in how the DHT holds the data in long-lived conductors. Mainly vouches are disappearing from the DHT, causing some people to be blocked from doing transactions.

We are investigating it and will try to upgrade to v0.0.48-alpha1 since there are some DHT fixes in that version.

Thanks for the testing guys :D, I’ll keep you posted.

1 Like

Hi Guillem,
Is the experiment still on ?

Hi @Loic! So not right now, we bumped into some holochain core issues when we tried to scale a bit up our network. Although, with the newer fixes available with v51, it should be much better, we’ll have to wait until holoscape is upgraded to that version.

1 Like

I am watching this with some interest.
If you don’t mind, I would like to have a go at shaping some of the characteristics of the currency based upon my Youtube video.
We are setting up a series of communities across Australia and a well designed Mutual Credit system is really important.

1 Like