Holochain Forum

Holochain hApp Launcher Demo-Networking Explained- Bootstrap Service and Proxy Server - (HiA19)

hApp Launcher is up and running and you can start installing and playing with hApps. For sure your feedbacks will help a lot in continuing the development of this tool.


Launcher: https://github.com/holochain/launcher/releases
Elemental-Chess: https://github.com/eyss/elemental-chess/releases
Elemental-Chat: https://github.com/holochain/elemental-chat-ui/releases/


00:00:00 Intro
00:04:26 Content of video
00:06:32 Launcher Demo with Elemental-Chat and Elemental-Chess
00:17:38 Networking in Holochain: Bootstrap Service
00:35:16 Networking in Holochain: Proxy Server
00:46:14 Tauri
01:04:43 Launcher bootstrap and proxy

Great thanks to @guillemcordoba


Reply Here…


These sessions are mostly suitable for programmers and designers, so if you would like to participate you need to fill-out this application in advance.

Apply for “Holochain in Action” meetings!

3 Likes

Quick question; does the Launcher change the keyboard language settings? It did so in my case (Swedish → English), but this might be an edge case; I am running Debian 10 on Qubes OS. It works though! :slight_smile:

Hey :slight_smile:

O.o it definitely shouldn’t, thanks for the info… What os are you running?

1 Like

I’m running Qubes OS (https://www.qubes-os.org/) and I think that my problem was just a coincident. I will try the Launcher in different VMs, just to make sure :slight_smile:

1 Like

It’s solved with 0.3.3 version
hI,
I recieved this message :This site can’t be reached

localhost refused to connect.http://localhost:16684/

Windows 10, Chrome

1 Like

Hello,
have the same problem. There isn’t anything on this port - my is: localhost:21416. After reinstall the elemental-chat.webhapp have the same problem, but the port is changed. I tried with “netstat -an | findstr ‘port’”, but it seems to be there isn’t any running process on this port.

@batomix @szaba77a
Which version of launcher are you running?

would you please also turn off your firewall(all Inbounds and Outbounds) and your Anti-Virus(if you have) and try again.

@guillemcordoba

v.0.3.2 is the version. I tried without firewall too, but the main problem is, that there isn’t any service running on the specified port.

Hi @szaba77a and @batomix ! Can you restart the launcher and see if opening the app works? There is a known issue with v0.3.2 in which the first time you install an app, the connection refused screen would load. This will get fixed in the upcoming release this week.

2 Likes

It worked for me, restarting the launcher.

1 Like

Hi Guillem and Hedayat, @guillemcordoba @hedayat

You are doing a great job.
I will do a presentation of Holochain on Saturday and I would like to use the Launcher to do a demo.

Could you please give more details how to configure the proxy and the bootstrap ?

I tried to implement Elemental-chat and elemental-chess on 2 computers and it is working fine for elemental chat but not elemental chess.

I did the launcher procedure for windows as presented and installed the 2 hApp with the same UID. I have the same DNA hash on both computer and different public key which looks good to me.
For the networking, I understood the principle presented but I had no clue on what to do. So I looked for proxy parameters on my computer and I found this page.


I went in my network parameters and copy the adress.
For the bootstrap, I copied the link in my web explorer and I got a ok.
I did this on the two computers and magically it works for elemental-chat but not for the elemental-chess.

For elemental-chess, on the computer with which I setup my first player, I don’t see the second player implemented on my second computers but on my second computer I see both.
I sent an invitation to player 1 but I don’t see the invitation on my first computer.

Do you have an Idea why ?

3 Likes

Hi @Loic ! Really good to hear from you, thanks for trying this out, and sorry for the late response.

So the error that you were seeing was actually a known issue of Holochain v108. You don’t need to put the proxy or bootstrap services in any of the configurations of your computer.

Can you try with these new releases? They should fix the problems you’re seeing:

1 Like

Thanks Guillem,
Elemental-Chess is working but I noticed some bugs.
The first player registered do not see the second one at first. Then I used the second player to invite the first one. I saw the invitation and the name of the second player on my first player account appeared and was able to play Chess. :+1:
I added a third computer on elemental-chat. I can see the publication of this new computer on the chat of the others users but the answers of these users don’t appear on the chat of the new users.
Not important for me but just to let you know.
The Launcher is very easy to use. Thanks again. :clap: :clap: :clap: