Holochain Forum

Help with Rust Language Features (RLS) vscode extension

I’ve got Holonix set up with a default.nix environment (using the Nix Environment Selector extension).

When I’m in the hApp root directory and I open a rust file, I get the following error:

could not find `Cargo.toml` in `/home/marcus/happs/core_concepts/cc_tuts` or any parent directory

and warning:

A Cargo.toml file must be at the root of the workspace in order to support all features. Alternatively set rust-client.enableMultiProjectSetup=true in settings.

Adding { "rust-client.enableMultiProjectSetup": true } to vscode settings does not fix the issue. Edit: it does!

So I open vscode in the zomes/hello/code directory, but I’m no longer able to point Nix Environment Selector to default.nix

Edit: Ah wait nevermind, RLS is working now from the happ root after I added that setting, I just had to restart vscode. I’ll leave this post around for discussion.

1 Like