Holochain Forum

Hc package fail (v0.0.52-alpha2)

Hello,

I’m a Computer Science Master’s Student looking to see if Holochain is a viable solution for Remote Monitoring Systems. I am just a beginner when it comes to coding in Holochain, but
I have written code for Holochain last year for my research proposal and it just ran fine.

Now, I am trying to run my hApp again (by first running hc package) but this error keeps showing up: (I am running nix-shell in v0.0.52-alpha2)

error: failed to select a version for the requirement `toml = "= 0.5.0"`
  candidate versions found which didn't match: 0.5.8, 0.5.7, 0.5.6, ...
  location searched: crates.io index
required by package `holochain_logging v0.0.7`
    ... which is depended on by `holochain_core_types v0.0.51-alpha1`
    ... which is depended on by `hdk v0.0.51-alpha1`
    ... which is depended on by `hdk_proc_macros v0.0.51-alpha1`

I have tried to replace the “0.5.0” in the holochain_logging file to 0.5.8 but the same error keeps popping up.

As much as possible, I do not want to recode since it would take up a lot of time. Is there a possible workaround for this?

Thank you.

Hi @Haruden! So unfortunately the version you wrote your application with (holochain redux) has been discontinued and for quite some time now, everything has moved to RSM. The concepts are the same and you can begin to migrate your code with this migration guide.

As far as that error goes, I’m afraid I don’t know but you’ll find a whole lot of problems if you keep working with redux, so I encourage moving to RSM :smiley:

This is noted @guillemcordoba. Thank you for the response :slight_smile:

I have also same issue any suggestion for this so please reply. thanks in advance.