Holochain Forum


Hi there

I tried to generate a happ with hc-happ-scaffold:

$ nix-shell https://nightly.holochain.love
$ hc-happ-scaffold user-happ-type-spec.json my-new-app


  "types": {
        "user": {
          "description": "Create and manage users.",
          "sharing": "public",
          "definition": {
                "name": "string",
                "dob": "string",
                "icNumber": "string",
                "nationality": "string"

it ends with this error:

[email protected] hc:package /home/admin/happ-scaffold/My-New-App/happ
cd dna-src && hc package

sh: line 0: cd: dna-src: No such file or directory
npm ERR! errno 1
npm ERR! [email protected] hc:package: `cd dna-src && hc package`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] hc:package script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/admin/.npm/_logs/2021-07-30T06_26_54_129Z-debug.log

[email protected] hc:generate-conductor /home/admin/happ-scaffold/My-New-App
node src/conductor-setup/generate-conductor

Error: error: The subcommand 'keygen' wasn't recognized

Any idea what to do?

Hum this is outdated tooling… Unfortunately hc-app-scaffold is deprecated. Where did you see docs or instructions to use it? We should probably delete those.

Is there any new similar tools?

I’m curious about this too, if there was a command line util to just generate a default project structure.

For modern tooling, take a look at, and git clone, the happ build tutorial.

git clone https://github.com/holochain/happ-build-tutorial.git my-project-folder
cd my-project-folder
rm -rf .git

Last line is to remove existing git data so that you can fresh run
git init
For your new project based on a good starter.


I’m sure this will come through sooner or later. For now, we can take our own shortcuts like the one I mentioned I guess


Thanks for answer. What a pity it is already deprecated…
I already tried happ-build-tutorial but it also ends with error…