Holochain Forum

Error when packaging app, tag not found

I’m using a clean linux machine from GCP, I installed nix following the next steps:

sudo /sbin/sysctl kernel.unprivileged_userns_clone=1

sh <(curl https://nixos.org/releases/nix/nix-2.2.2/install)

. /home/jhonatan_hernandez/.nix-profile/etc/profile.d/nix.sh

And installed holochain running:

nix-shell https://holochain.love

and… this happened:


[nix-shell:~]$ hc --version
hc 0.0.29-alpha2

[nix-shell:~]$ hc init test
Created new Holochain project at: "test"

[nix-shell:~]$ cd test

[nix-shell:~/test]$ hc generate zomes/my_zome
> cargo init --lib --vcs none
     Created library package
Generated "my_zome" Zome

[nix-shell:~/test]$ hc package
> cargo build --release --target=wasm32-unknown-unknown --target-dir=/home/jhonatan_hernandez/nix-holochain/my_zome/target
    Updating git repository `https://github.com/holochain/holochain-rust`
error: failed to load source for a dependency on `hdk`

Caused by:
  Unable to update https://github.com/holochain/holochain-rust?tag=0.0.29-Alpha2

Caused by:
  failed to find tag `0.0.29-Alpha2`

Caused by:
  reference 'refs/tags/0.0.29-Alpha2' not found; class=Reference (4); code=NotFound (-3)
Error: Couldn't traverse DNA in directory "/home/jhonatan_hernandez/test": command cargo build --release --target=wasm32-unknown-unknown --target-dir=/home/jhonatan_hernandez/nix-holochain/my_zome/target was not successful

Do you have any idea of how can I make it work? I tried using several older versions of holochain, but I got the same error:

failed to find tag `0.0.X-AlphaX`

Several versions had a missing tag. A new release will be cut this weekend/by Monday. I recommend waiting for the new release and try again to see if it solves the issue.

1 Like

@dhtnetwork @JhonatanHern this is fixed here https://github.com/holochain/holochain-rust/pull/1707

the fix should propagate to holonix in the next release

Is this fixed in v0.0.30-alpha4?