Holochain Forum

Error during "Install Holochain Tools" step: gzip: stdin: invalid compressed data--crc error

Following the steps to install Holochain environment on Windows under Vagrant as described in https://developer.holochain.org/docs/install/. I’ve got to the point where I am ssh’ed into the box. When I run

nix-shell https://holochain.love

I get the following error/output (this is with --show-trace):

unpacking 'https://github.com/NixOS/nixpkgs/archive/821c7ed030bca86c8217e6d20df1f01c6474adf4.tar.gz'...    
tar: Skipping to next header

gzip: stdin: invalid compressed data--crc error

gzip: stdin: invalid compressed data--length error
tar: Child returned status 1
tar: Error is not recoverable: exiting now
error: while evaluating the file '/nix/store/w347s2kvhyhvrgxcm0swrj2wrcdn1dib-holochain.love/nixpkgs/default.nix':
program 'tar' failed with exit code 2

The only deviations from the specified instructions are that I am using the latest VirtualBox and Vagrant installs, not the older versions linked in the instructions as those were already installed.

Thoughts?

Matthew

CCing you two at Arthur’s request: @artbrock @philipbeadle

1 Like

@MatthewNichols try again? looks like a random failure, like the tarball didn’t download properly or something?

Thanks. Sadly I get the same result. I am happy to run any debugging you suggest; my knowledge of Nix is pretty close to zero :slight_smile:

it just worked for me on a nixos machine

[thedavidmeister@nixos:~/holochain-2020]$ nix-shell https://holochain.love

[nix-shell:~/holochain-2020]$

that’s not vagrant though, i just smoke tested it on the normal shell

cc: @mmahut @BrightOne

@MatthewNichols can you please try to run the following and uploading the output somewhere?

nix-shell -vvvvv  https://holochain.love