Holochain Forum

Difficulties with installation

Hi,
I got an Ubuntu setup on my Win10 and I’m trying to get a Holo environment going.
I saw that there are multiple different manuals, and I tried several of them and kept a wall over and over again.

That one for example
https://developer.holochain.org/docs/install/
Just didn’t seem to actually install the holochain…

[nix-shell:~/holochain]$ holochain --version
bash: holochain: command not found

Also tried that one


Didn’t get very far either…
    [nix-shell:~/holochain]$ hc-merge-test
    + export RUST_BACKTRACE=1
    + RUST_BACKTRACE=1
    + hn-rust-fmt-check
    checking rust formatting
    /nix/store/jrdiihdziy8p6c3wsp1ijkng95msfvq7-hn-rust-fmt-check/bin/hn-rust-fmt-check: line 3: /nix/store/58s1wvgfb6x2gcs203fn4jvgw8iby7pq-rust-1.48.0-2020-11-16-7eac88abb/bin/cargo: cannot execute binary file: Exec format error

Is this just still in too early stage for developers to take a crack at it, or am I doing something wrong?

Ping @steveeJ @pauldaoust @thedavidmeister

When following the guide you’ve linked you should drop into a shell that has holochain installed. Make sure that you’re not running the commands inside the holochain repository, which you apparently have cloned to your filesystem as hc-merge-test is only available there.

I’ll be able to help you only as far as choosing the appropriate shell files, but as the install guide notes we don’t have experience with and support for WSL2 at the moment. Therefore further feedback is highly appreciated!

Hi,
Thanks for your response.

If not in the holochain repo that I just cloned then where? It doesn’t seem that I can run the nix shell outside the repo…

Hey,

copy and pasted from the docs you linked :slight_smile:

$(nix-build https://holochain.love --no-link -A pkgs.holonix)/bin/holonix

This command is agnostic to PWD, as long as the Nix tools are available in PATH. To be explicit, you don’t have to clone the holochain repository for this to work.

^^ this above injects the holochain binary into your current shell session and cleans it up when you’re done

when we release a new holochain version you’ll get the new version with your new shell sessions

(note: with the instructions in the current install guide, you don’t get auto-updates. Personally I kinda like that, cuz I always know where I’m at, but it does require intentional effort to get updated.)

Hmm, ran that again and it seems to have finished with an error

error: the group 'nixbld' specified in 'build-users-group' does not exist

That’s probably the reason it doesn’t work. :slight_smile:

Thanks for the help.
Is there a way around that or do I need to wait for an update?

1 Like

I am currently getting the same error. I have been trying to figure out how to fix this for the pass hour or two. I ran sudo addgroup nixbld and now am getting error: the build users group 'nixbld' has no members. Is there anything anyone can recommend to fix this?

Yeah, same here.
Pretty painful stuff. Even spun up a docker container and a Kali dist, just in case. Nothing works…

Got through most of the other manual (I think). Finally got to a place where it said something about a conductor. No idea what should come next though…

1 Like

Can you check if your ./default.nix exists?

It seems like mine doesn’t. I’m trying to see if that’s the issue

This has come up a lot recently and I think it’s worth to just create this group in your system in order to make the script work. You don’t necessarily have to add your user to the group, so an empty group should be fine. This command works on Ubuntu for example.

If you don’t want to go through creating the group you can also skip the holonix wrapper script altogether and simply type nix-shell https://holochain.love. Note that this has the disadvantage of not querying our binary cache and thus has to compile all the binaries locally on your machine.

1 Like

Creating the group doesn’t work. It just gives a different error

I’ll try to simply type that command when I get the chance and see where it takes me.

Though, even if it would work, the manual seems to just stop at that point…

Let us know how that went! My guess is that it’ll take a while – 20-30 minutes wouldn’t surprise depending on the machine – to build the shell environment and then you’ll successfully enter the nix-shell. The installation manual ends there because it’ll have produced the environment that contains the holochain binary and other utilities that you’ll use during hApp development!

If you’re looking for further inspiration I’ll just leave this here as I’m exploring this myself: https://holochain-gym.github.io . It takes you beyond the installation, shout-out to @guillemcordoba :raised_hands:

1 Like