Holochain Forum

Compiling error with hello zome: error[E0433]: failed to resolve: could not find `document_join_macro` in `futures_util`

Hi Folks,

Having followed the instructions in the tutorial, I get the following error when compiling:

error[E0433]: failed to resolve: could not find document_join_macro in futures_util
–> /home/hank/.cargo/registry/src/github.com-1ecc6299db9ec823/futures-0.3.2/src/lib.rs:561:15
|
561 | futures_util::document_join_macro! {
| ^^^^^^^^^^^^^^^^^^^ could not find document_join_macro in futures_util

error[E0433]: failed to resolve: could not find document_select_macro in futures_util
–> /home/hank/.cargo/registry/src/github.com-1ecc6299db9ec823/futures-0.3.2/src/lib.rs:584:15
|
584 | futures_util::document_select_macro! {
| ^^^^^^^^^^^^^^^^^^^^^ could not find document_select_macro in futures_util

error: aborting due to 2 previous errors

I’ve attached screenshots for all of the commands I entered.

I am on Ubuntu 16.04 LTS

Has anybody else had this problem?

Thanks,

Hank

Having the same error here.
Command hc package fails even with a freshly created zome from hc generate command.

Any help from the core team or the community would be appreciated.

seems like other people are experiencing the same issue with rust.

pinging @pauldaoust just in case this needs attention.

Same here for newest version - hc 0.0.47-alpha1

Hi everyone, also had this error, this was provoked by the recent release of 0.0.48-alpha1 I think. Anyway here is the temporary fix, you need to add this to the dependencies section of your Cargo.tomls:

futures = "=0.3.2"
futures-util = "=0.3.2"
futures-macro = "=0.3.2"
4 Likes

As far as I can tell, I’m on version 0.0.47-alpha1.

However, your fix seems to have done the trick.

Thanks.

Yes I mean, this only happened when holochain themselves upgraded to 0.0.48-alpha1, and then some dependency on our side was pulling the newer version and locking the futures crates. At least this is the only thing that makes sense to me :smiley:

Thank you!