Holochain Forum

Compiling error : error: linking with `rust-lld` failed

Hi guys,

15 days ago my code was compiling fine, now I get this error message each time I try to compile :

error: linking with rust-lld failed: exit code: 1

Same happens when I generate a new project through the CLI.
I did try Markus’ solution (https://github.com/holochain/holochain-rust/issues/1573) to no avail.

Is it only me? I’d find it rather strange : I use Holonix, everything should be properly updated and linked, right?

I wonder if it’s related to Error while trying "Hello Holo tutorial"! – different error messages, but may have the same root. Seems that 0.0.34 is kind of a flaky release; I think we’re all looking into it.

Thanks Paul!
for information : I had the same pb with 0.0.33-alpha6

Update : no, not related to this problem, hdk_proc_macros isn’t even declared in my Cargo.toml (tried it though…didn’t work :slight_smile: )

Huh, weird. Ummm @freesig have you come across this one yet?

I have not no. I can have a look, although I don’t currently have access to a windows system.

Could I see your Cargo.toml in your zome @ReversedK
Also which holochain are you using?

holochain --version

Hi Tom, sure.
I experienced this problem with hc 0.0.34-alpha1
Note that this happens also when I generate a brand new project and zome through the CLI
I posted an issue on the Holonix github (https://github.com/holochain/holonix/issues/104)

Here is my cargo file :

[package]
name = “wtfg”
version = “0.1.0”
authors = [“vagrant”]
edition = “2018”

[dependencies]
serde = “=1.0.89”
serde_json = { version = “=1.0.39”, features = [“preserve_order”] }
serde_derive = “=1.0.89”
hdk = “=0.0.34-alpha1”
holochain_wasm_utils = “=0.0.34-alpha1”
holochain_json_derive = “=0.0.17”

[lib]
path = “src/lib.rs”
crate-type = [“cdylib”]

Hi @ReversedK Could you find a solution for this problem? Now, suddenly, I got the same error message, when I try to compile:

I use the newest hc version: v0.0.38-alpha14 and my Cargo-toml file looks ok.