Holochain Forum

Can't install Holochain v25 from Github (Dev Camp)

Hey guys, I can’t install Holochain v25.

It’s need for the Dev Camp so Thomas suggested I post this here as well so the core dev team can have a look at this.

I used this command:
nix-shell https://github.com/holochain/holonix/archive/0.0.29.tar.gz

The standard “nix-shell https://holochain.love” command still completes without errors though. (I had installed and tested it previously.)

Here’s part of the output (Powershell in Win10):

curl: (56) OpenSSL SSL_read: SSL_ERROR_SYSCALL, errno 104
error: cannot download conductor-0.0.25-alpha1-x86_64-generic-linux-gnu.tar.gz from any mirror
builder for ‘/nix/store/l22yaqcd059ncifig8c5vfjpvy3dybyl-conductor-0.0.25-alpha1-x86_64-generic-linux-gnu.tar.gz.drv’ failed with exit code 1
building ‘/nix/store/5fsigmpil7kbq15z5s95wyyghwyd26i0-hc.drv’…
cannot build derivation ‘/nix/store/l59irdp485xkg4pr1dqlz9hmm2rldjgc-holochain.drv’: 1 dependencies couldn’t be built
error: build of ‘/nix/store/5fsigmpil7kbq15z5s95wyyghwyd26i0-hc.drv’, ‘/nix/store/72yb42nm87102ida9aljpm706hb03bbl-hn-release-github.drv’, ‘/nix/store/hf86sy9vr5rahncxjp14i4203bywmmbl-hn-release-push.drv’, ‘/nix/store/l59irdp485xkg4pr1dqlz9hmm2rldjgc-holochain.drv’ failed`

`[vagrant@nixos:/vagrant]$

Hi @sachaweb thanks for the flag. We are looking into it. So it’s not just an internet connection issue? Have you tried again? Were other DevCamp participants able to pin to v25? Will keep you posted.

@sachaweb curl error looks like a bad internet connection to me

i just ran

nix-shell https://github.com/holochain/holonix/archive/0.0.29.tar.gz

and it dropped into the shell

try again on a different network and report back?

1 Like

@thedavidmeister:

curl error looks like a bad internet connection to me

Oh gosh, I guess I will have to move my desktop PC to another floor at home and even try a LAN cable at long last… Will do tomorrow as I’m working on that computer remotely today. The wifi connection is a bit weak indeed where it’s now.

@dhtnetwork:

Were other DevCamp participants able to pin to v25?

Probably most, yes, but people using Windows had other issues, perhaps similar. Someone suggested using a Fedora distro with an older version of the Oracle VM…

Will keep you posted…

@sachaweb do you know what any of those other windows issues were?

Can’t tell exactly, there are a few sparse comments on our Mattermost chat channel here:
https://chat.holochain.org/appsup/channels/devcamp5-live-support

Search for ‘Windows’ on that page. Not sure if it’s been solved meanwhile.

@sachaweb i see, with the vagrant issues… i wonder if that could be resolved by grabbing a bog standard ubuntu box (instead of the “prewarmed” nix box we ship) and installing nix-shell on that :thinking:

the WSL issue looks like using WSL 1 instead of WSL 2 and not setting the extra config https://docs.holochain.love/docs/install/

sandbox = false
use-sqlite-wal = false

in /etc/nix/nix.conf