Holochain Forum

Cannot install holochain on Linux

Hi, I’m getting started with the installation process for Linux. After the process failed on my Mac, I think due to incompatibilities between some rust libraries and ARM architecture, I spun up an EC2 instance running Amazon Linux to try a fresh installation there. I’m able to install NixOS. When I install Holochain however, I get the following error consistently.

error: could not compile cranelift-codegen

Caused by:
process didn’t exit successfully: rustc --crate-name cranelift_codegen --edition=2018 /build/holochain-vendor.tar.gz/cranelift-codegen/src/lib.rs --error-format=json --json=diagnostic-rendered-ansi,artifacts --crate-type lib --emit=dep-info,metadata,link -C opt-level=3 -C embed-bitcode=no --cfg 'feature="arm64"' --cfg 'feature="gimli"' --cfg 'feature="std"' --cfg 'feature="unwind"' --cfg 'feature="x86"' -C metadata=13b469b344f08bae -C extra-filename=-13b469b344f08bae --out-dir /build/source/target/x86_64-unknown-linux-gnu/release/deps --target x86_64-unknown-linux-gnu -C linker=/nix/store/88ghxafjpqp5sqpd75r51qqg4q5d95ss-gcc-wrapper-10.3.0/bin/cc -L dependency=/build/source/target/x86_64-unknown-linux-gnu/release/deps -L dependency=/build/source/target/release/deps --extern cranelift_bforest=/build/source/target/x86_64-unknown-linux-gnu/release/deps/libcranelift_bforest-b5e3f7b4e2b8d590.rmeta --extern cranelift_codegen_shared=/build/source/target/x86_64-unknown-linux-gnu/release/deps/libcranelift_codegen_shared-6473a8b7b8c2f158.rmeta --extern cranelift_entity=/build/source/target/x86_64-unknown-linux-gnu/release/deps/libcranelift_entity-ae254530da79ceda.rmeta --extern gimli=/build/source/target/x86_64-unknown-linux-gnu/release/deps/libgimli-79429a511e1a450f.rmeta --extern log=/build/source/target/x86_64-unknown-linux-gnu/release/deps/liblog-7d6e2dc6bf8af126.rmeta --extern regalloc=/build/source/target/x86_64-unknown-linux-gnu/release/deps/libregalloc-5f7f842308e61674.rmeta --extern smallvec=/build/source/target/x86_64-unknown-linux-gnu/release/deps/libsmallvec-93a10ba89f62bc4b.rmeta --extern target_lexicon=/build/source/target/x86_64-unknown-linux-gnu/release/deps/libtarget_lexicon-9fa867bf1e271bfb.rmeta --cap-lints allow (signal: 9, SIGKILL: kill)
builder for ‘/nix/store/5hxb52bfikbb6iv5k7dg7ymnnmrhz7kl-holochain.drv’ failed with exit code 101
error: build of ‘/nix/store/5hxb52bfikbb6iv5k7dg7ymnnmrhz7kl-holochain.drv’, ‘/nix/store/akcqbcxy2r3s6xnv6qfi3xgjrcbfbb99-holochain.drv’, ‘/nix/store/x1nqmfhdaqdi8382vmixmqgvf68iiv4d-holochain.drv’, ‘/nix/store/yz2mgpgsw6fd2npkrf6q9dlqq7sqrcl3-holochain.drv’ failed

I was wondering if anyone else ran into this issue and has solved it.

Just to cover all bases. You tried bashing
$ nix-shell https://nightly.holochain.love

Also, there is a holochain launcher being released as an .appImage at:

If you’re downloading the Holochain git repository and trying to cargo build, probably not practical :sweat_smile:
Hopefully you didn’t know all this already. :confused:

mmm or even use nix-shell directly from the holochain repo

it does depend a bit on what you’re trying to achieve, do you want to use holochain as an end-user of happs, to develop happs, or you want to work on holochain itself to see what’s under the hood?