Nix-shell does not have latest version of holochain

What’s up guys, it’s been a while. Running nix-shell is giving me holochain v0.0.38-alpha14, should be v0.0.40-alpha1, right? How do I get the latest in nix-shell?

Hi @vanarchist the latest Holochain Core version is v.0.0.40-alpha1, but it looks like love could still be pinned to v.0.0.38. FYI, check out this post from Meister. TLDR:

Check out this post about our release process and the reasoning behind pinned versions. Holochain Release Blessing.

In the meantime, I’ll look into the issue. Check out the Holochain Release Blessing post if you want to get the latest version.

Thanks @dhtnetwork, that helped. I ran nix-shell and that got me the latest stuff. It is a bit confusing as says that is a convenience url that points to the master branch of the holonix repo on github. Seems like that documentation is out of date.

1 Like

Things are moving quite fast, and you are right documentation needs to be updated to reflect the latest.

Lets get those docs updated : ). Note to us : ).

1 Like

Hmm, turns out hc generate doesn’t work when I use nix-shell I ran hc generate zomes/geospatial rust-proc and got:

downloading and extracting tarball from:
 > zomes/geospatial/

but it doesn’t create anything.

hmm interesting @thedavidmeister what do you think? Anything else Van can do?

hmm, if there’s a bug in hc generate we need to fix it before we bless the release… can we get a bug report up on holonix? @dhtnetwork @vanarchist

Hi @vanarchist it would be a big help if you can submit a bug report with all the details. We’ll keep an eye on the issue and help resolve it once it’s on GitHub.

In terms of the docs, we’ll bundle and address doc changes in the near future. In the meantime, there is an issue so you can track the progress.

1 Like

@dhtnetwork I’m having the issue described by the title of this thread. After running nix-shell, I am getting:

hc --version
hc 0.0.38-alpha14

holochain --version

Holochain version 21? Confused by this. This is after a recent upgrade to Catalina. Have you seen this issue before?

Thanks John. What??!!! that is really odd. version 21-alpha? We are at v.0.0.40-alpha1. How did you get 21-alpha1?

I just updated to Catalina and am having some issues too. I’m going to see if we can troubleshoot today and will provide update.

Thanks for flagging.

Hey @J-Krush, this could be an issue with having an old Holochain version and not related to Catalina. Can you double check? You may need to remove an older version.

@dhtnetwork That’s what I thought too. I believe I’ve removed all versions. Is there a way to check easily?
On my last attempt I tried installing Holochain via
nix-env -f -iA holochain.holochain holochain.hc
Is there a version of this command that can take an argument with an effect like --pure?

Yes, there is something similar. Tom is going to provide you more details on how to resolve this (a few hours).

1 Like

Hey @J-Krush what is the output of which holochain?

or command -v holochain if you don’t have which installed

Output: /Users/krush/.cargo/bin/holochain

Thanks for that tip @freesig and @thedavidmeister - I removed the holochain file at that location and set things up again, and now it is showing the correct holochain version. Thanks!


@J-Krush 90% of the time a very old non-nix-shell compiled binary is the culprit for stale versions :slight_smile:

1 Like

@thedavidmeister Totally, I just didn’t know how to get there! Thanks again.