Holochain Forum

Help us by testing your hApp over the Internet with Holoscape and sim2h!

Hi Nico, I’ve also asked another user to document their experience with Holoscape. I’ve submitted an issue with notes from this user.

Tried out the just-now released v0.0.4 for Mac.

  1. Installation was no different from any other (untrusted) Mac app. :tada:

  2. Basic Chat could not be installed due to the “Hash of found file is different” problem:

  3. After having installed one app successfully (I started with the Peer Chat), this prompt showed underneath all app pages, regardless of whether I had installed it or not.

  4. After an app has finished installing, everything is cleared out except the app’s listing. This confused me several times, as I was wondering if something had gone wrong. Some sort of confirmation prompt here would be nice. (I’m guessing this is where the prompt mentioned in (3) is supposed to show up!)

  5. All apps except Basic Chat installed and ran without issues :muscle:

2 Likes

Hi @erlend_sh Thank you for testing and providing feedback on your experience.

Yes, @ThomasMiller and @erlend_sh, there was a bug in hc's hash calculation which was mistakenly changing the DNA if no properties were given (just hc hash, no hc hash --property x=1). This got fixed recently in v0.0.40-alpha1.

  1. This new version should fix your problem @ThomasMiller - that is, your workflow should be fine and not show a hash mismatch anymore if you use all the newest builds.
  2. That fix is exactly what broke the installation of Basic Chat which had the old/wrong DNA hash in its bundle. That got fixed now as well - thanks for pointing this out @erlend_sh! Please try again, it should work now. And if it does, we can chat over there :slight_smile:
1 Like

Oh, and yes: the UX is still … sub-optimal. There is a major revamp on its way, but that is not (yet) at the top of our priority list.

Okay, tried at least 5 times tonight.

Outcome: unable to run any app

  1. Install Holoscape
  2. See images
  3. hApps tray – empty.
  4. Will try again another day.

It looked like the hApp was installed but it wasn’t showing up in the hApp list in the tray icon. It could be a catalina problem but we will keep digging

Small tasting testing of Holoscape sim2hl. I work with OS windows pro. To install WSL2 https://autoize.com/xfce4-desktop-environment-and-x-server-for-ubuntu-on-wsl-2/, followed by nix-shell and https://github.com/holochain/holoscape .
https://youtu.be/wzMxVLwdqVQ

1 Like

Thanks for sharing this Wladoo, I too am on windows, and having followed the directions, I’m seeing an ubuntu desktop after running startxfce4, but there is no launcher bar, and when right clicking to open a terminal it has me select a terminal, but no windows will open.

Does this log tell you anything?

pnewell@Peter-Desktop:~$ startxfce4
/usr/bin/startxfce4: X server already running on display 172.20.0.1:0
gpg-agent[398]: WARNING: “–write-env-file” is an obsolete option - it has no effect
gpg-agent: a gpg-agent is already running - not starting a new one

(xfce4-session:387): xfce4-session-WARNING **: 10:22:24.335: gpg-agent returned no PID in the variables

(xfce4-session:387): xfce4-session-WARNING **: 10:22:24.336: xfsm_manager_load_session: Something wrong with /home/pnewell/.cache/sessions/xfce4-session-172.20.0.1:0, Does it exist? Permissions issue?
xfsettingsd-Message: 10:22:24.374: Skipping screen 0, it already has an xsettings manager…

(xfsettingsd:415): libupower-glib-WARNING **: 10:22:24.377: Couldn’t connect to proxy: Could not connect: No such file or directory

(xfsettingsd:415): libupower-glib-CRITICAL **: 10:22:24.377: up_client_get_lid_is_closed: assertion ‘UP_IS_CLIENT (client)’ failed

(xfsettingsd:415): GLib-GObject-WARNING **: 10:22:24.377: invalid (NULL) pointer instance

(xfsettingsd:415): GLib-GObject-CRITICAL **: 10:22:24.377: g_signal_connect_data: assertion ‘G_TYPE_CHECK_INSTANCE (instance)’ failed

(xfwm4:401): xfwm4-WARNING **: 10:22:24.439: Error opening /dev/dri/card0: No such file or directory
env: ‘Thunar’: No such file or directory
env: ‘xfce4-panel’: No such file or directory

** (xfdesktop:409): WARNING **: 10:22:24.501: Failed to get system bus: Could not connect: No such file or directory
xfsettingsd: Another clipboard manager is already running.
Gtk-Message: 10:22:46.486: GtkDialog mapped without a transient parent. This is discouraged.
[error]No input, aborting
Gtk-Message: 10:22:56.870: GtkDialog mapped without a transient parent. This is discouraged.

I’ve mostly got it working following the instructions on this page.

I’m now able to launch holoscape and got to the page to set the networking, but after clicking next the whole window disappeared. From the console log it appears as though the conductor is running, but I’m not getting any holoscape UI. Subsequent runs no longer prompt with the networking screen and just close right away.

Now I see that it is running successfully and that the screen is expected when there aren’t other things installed. I’ve now successfully installed PeerChat!

I would suggest either a log message to console or another admin screen with something to happen when there aren’t apps installed.

Congrats on successfully installing PeerChat! Let us know your experience. How’s the speed? Do you see other chat rooms?

Speed is fine, I don’t see other chat rooms or anyone online, but I do see conversations I’ve started that persist after reboot.

Refreshed this morning and I now see wladoo!

3 Likes

Great to hear, thanks for the update Peter! Woohoo!

I’m trying to start 0.0.4 on a mac. The start screen appears for some short seconds and then disappears. Then, nothing. The tray icon is there but no more action.

I ran the 0.0.3 version successfully, maybe I should clear all data from previous install and start fresh?

Where should I clean out the old app data?

EDIT: Forget about 0.0.4. 0.0.5 runs fine through nix-shell following the instructions on https://github.com/holochain/holoscape

Nice work! :+1::pisces:

3 Likes

Great! Although 0.0.5 is not yet released, but almost :slight_smile: So you basically got the release candidate from source.

The data is in XDG compliant user directories. On macOS that would be ~/Library/Application Support/Holoscape-default.

And yeah, general statement about the UX of <=0.0.4 and the lack of a main window, that is fixed with a major UX revamp coming with 0.0.5. You could also try running it from source, @petersgrandadventure, as @kristofer did, or wait until the next binary release. There were a few last minute fixes, but I really want get it out tomorrow!

1 Like

@lucksus I guess there isn’t time for more features before the release of 0.0.5? For future releases, one thing that would be Great is the ability to detach console / devtools to a separate window. Currently the console ends up below the content of the hApp which makes debugging really hard. I also get a sense that the console is not picking up output from the indivudual hApps, but it is difficult to really tell since the view is mostly hidden. :slight_smile:

EDIT: Managed to detach devtools, menus are clickable first time window appears. But as I suspected, console output is not from hApp but from Holoscape only. Is there a way to open devtools for an indiuvidual hApp?

(ps. I’m having difficulties with the settings, connecting my local hApp with the DNA, the UI instance etc. It seems don’t get a reply from /_dna_connections.json)

2 Likes

Is this currently possible? If so, where do I open the bundle file from Holoscape? I’ve managed to install by editing the config files manually but would like to try with the bundle as well.