Holochain Forum

About the RSM Technical Discussion! category

did you install the wasm32-unknown-unknown target for your cargo?

No, how do I do that? Thanks :slight_smile:

Ideally be good to get this working in WSL2 rather than standalone… :slight_smile:

rustup target install wasm32-unknown-unknown

2 Likes

Great thanks, got further. WASM now builds. What has happened to dna-util? The repreo is not there anymore? I think it got integrated into the conductor? But when I view the help for it in the terminal it doesn’t list any commands for creating the dna?

I found this:

But hc is not a recognised command? Any ideas? :slight_smile:

dna-util has been deprecated, and its functions moved into “hc” .

What environment were you using, where “hc” is not found. Were you in the nix-shell from the nix file that’s in the dna-build-tutorial project?
If you were, it should be there

nix-shell doesn’t work properly on WSL2 in Windows, had nothing but issues with it (see some of the latest above) so now need to use crates directly as a workaround.

I seem to be having luck with this raw command to install hc:

cargo install holochain_cli --git https://github.com/holochain/holochain --branch main

Ok great thanks. :slight_smile:

Will try it…

I managed to get nixshell working but the odd thing is hc was still not found?

I thought it was suppose to be all setup and ready to go in nix-shell? It took over 1.5 hours to build on my machine! lol

Cheers
D.

Good news, I got hc working :slight_smile: :heart:

I got the conductor working with ElementalChat! Yay! :slight_smile: Only took 6 months but we got there in the end! :wink: lol

Now I can finally get back to HoloNET RSM. I tried connecting and I got back the error:

Unable to connect to the remote server. No connection could be made because the target machine actively refused it. (localhost:8888)

I am running the conductor inside a nix-shell in WLS2 on Windows 10. Is the port being blocked somewhere? The odd thing this use to work fine with the old Redux version.

Any help would be really appreciated thanks. :slight_smile:

Cheers
D.

1 Like

I noticed it is a lot more complicated with more steps than it use to be. This is what I hope to hide away under the hood with HoloNET and the Low-Code .NET HDK I have been working on (I actually finished this last Sept and was about to release it when RSM was announced, so I had to shelve it until I could add RSM support so you can imagine my frustration! :wink: lol

It dynamically generates rust and c# code from templates from a meta-model. It makes building hApps much quicker and you can also debug them because it uses rust for the DAL (Data Access Layer) and it uses C# for the BLL (Business Logic Layer). So people can focus on their app idea rather than the technical DAL stuff. This uses HoloNET under the hood to connect to the conductor. If we could have a Windows binary again I could then auto-start and shutdown the conductor like it use to before nix came along… it could also automatically package the dna/hApp etc… :slight_smile:

Oh, and it also bridges into any other platform/network/api/protocol using the OASIS API so currently it supports Holochain, EOSIO, Ethereum, MongoDB, SEEDS, Neo4j, SQLLite & IPFS. Soon ThreeFold, ActivityPub, SOLID and many more will be added… :slight_smile:

This is to allow people to bridge into Holochain and create a easy migration path to it. It also uses the best bits of each tech stack/platform to harnesses the power of unity consciousness… and removes all silos once and for all. Also when you build on it (OAPPs) you never need to migrate your code again and is always future proof because the OASIS API handles this for you… :slight_smile:

People also no longer need to keep learning new languages, stacks, etc. They just use the simple intuitive abstraction API over everything… :slight_smile:

So the only thing holding up releasing this is getting HoloNET to connect to the new RSM conductor so any help with this would be REALLY appreciated.

Oh, and myself and Walter plan to integrate GO (Generative Objects - also written in c#) and the OASIS/.NET HDK so this would be even more powerful then! :slight_smile: :heart:

Also, want to integrate into CRISPR ASAP too… :slight_smile:

Ready to live the Low Code Dream? :wink: :heart:

Cheers
D.

1 Like

Wow! Great!

Anyway, before I jump back into development-work, a few questions:

  • @guillemcordoba, is tryorama usable yet?
  • Has anyone had any success with connecting UI (natively running on Windows) to the DNA instance (cell) running the conductor in WSL?

'Cause, what’s the point of developing (h)apps if one can’t actively test and use them… Last time, I had a very hard time with testing… Are things (relatively) stable now? How do you guys (the core team, and @guillemcordoba) test or connect to cells (in Windows; though I’m damn sure none of you are on Windows)? I’d request that one of you go through the pain of going through the whole (h)app development cycle on Windows and share your experience and know-hows from the experience… [I hate being the first in anything; especially being the first in “going through pain”… Haha!]

1 Like

Yeah I second that. Up to now it seems it’s me who has had to be the guinie pig that needs to go through the pain! Lol :wink:

1 Like

Yes, tryorama is usable again. You can see the dna build tutorial repo for a full working example of everything.

I don’t have the bandwidth to go through that cycle, more so as windows doesn’t have native nix support. And I think that apart from that there is one piece in holochain core that doesn’t have windows support yet. I’ve been going through that experience of advancing through things without any or little documentation, and it feels great to share the discoveries afterwards. I encourage you to go through it if you really want something to work (eg in Windows without any VM), as of now everything is yet to be built (templates, tutorials, guides), and I’ve found myself overworked with everything, so it would be great to have others be involved in that as well :slight_smile:

3 Likes

Yeah know the feeling about being overworked brother! :wink: lol also battling through health and adrenal issues, which has unfortunately slowed me down a lot but we will get there in the end! :slightly_smiling_face::heart::innocent::blue_heart::pray:

HODL! :innocent::pray::heart::blue_heart::rainbow::partying_face::smiling_face_with_three_hearts:

1 Like

Knew it was too good to be true! lol

I just tried running the conductor again today and got back another new fun error! lol

[nix-shell:~/holochain-rsm2/elemental-chat-develop/elementalChatHapp]$ hc sandbox generate ElementalChat.happ
hc-sandbox: Creating 1 conductor sandboxes with same settings
hc-sandbox: Config ConductorConfig { environment_path: EnvironmentRootPath("/tmp/tmp.xqmx7dSJtZ/VS7ZNAipLD2AIFCFc3fnP"), use_dangerous_test_keystore: false, signing_service_uri: None, encryption_service_uri: None, decryption_service_uri: None, dpki: None, keystore_path: Some("/tmp/tmp.xqmx7dSJtZ/VS7ZNAipLD2AIFCFc3fnP/keystore"), passphrase_service: None, admin_interfaces: Some([AdminInterfaceConfig { driver: Websocket { port: 0 } }]), network: None }
hc-sandbox: Created directory at: /tmp/tmp.xqmx7dSJtZ/VS7ZNAipLD2AIFCFc3fnP Keep this path to rerun the same sandbox
hc-sandbox: Created config at /tmp/tmp.xqmx7dSJtZ/VS7ZNAipLD2AIFCFc3fnP/conductor-config.yaml

Conductor ready.
Error: Failed to install app: Expected AdminResponse::AppBundleInstalled but got Error(InternalError(“Conductor returned an error while using a ConductorApi: EntryDefStoreError(DnaError(WasmError(Compile(“link error: Import not found, namespace: env, name: __debug”))))”))

[nix-shell:~/holochain-rsm2/elemental-chat-develop/elementalChatHapp]$

Which is very odd considering it was working yesterday fine?

Any ideas guys? Thanks.

You have to laugh rather than cry! :wink: lol

Any ideas anyone? I’m keen to get this working ASAP, it will then enable the .NET HDK to finally be finished and bring the flood of devs, PR and resources we all need! Thanks :slight_smile: :heart:

I went back to the standalone ubuntu install because I am blocked as I said above.

But on that I get a different error:

[email protected]:~$ nix-shell https://holochain.love
these derivations will be built:
/nix/store/9333vz9a8zkvwlmrknpkbz13s187nipc-rust-1.48.0-2020-11-16-7eac88abb.drv
/nix/store/wvy5hdbikg16png07345v0r4vbi82sa6-source.drv
/nix/store/gp3sy26xj1cjm9ff5ks9x1vrgv9ncrm8-lair-keystore-vendor.tar.gz.drv
/nix/store/0mkrii7mqq7kyimqzx6q904dh51d83jp-lair-keystore.drv
/nix/store/spyyygb6m17f9j417qxy72dhb9a0rmi9-source.drv
/nix/store/bm63nh5pzas4m6c1q6v54w98wjp81dfy-holochain-vendor.tar.gz.drv
/nix/store/jhp3w38j6z39w6mjrbh0brmnzi5dqri8-holochain.drv
/nix/store/ndl58c0vza711vi4lp3h2yi088l6p8z5-holochain.drv
/nix/store/ysx0i9k33dl9dpxb8hk9ycpf1yalwf27-holochain.drv
error: creating log file ‘/nix/var/log/nix/drvs/93//33vz9a8zkvwlmrknpkbz13s187nipc-rust-1.48.0-2020-11-16-7eac88abb.drv.bz2’: Permission denied
[email protected]:~$

Any ideas? Thanks. :slight_smile:

I tried the crate way and that worked fine until I ran the holochain command, which gave this error:

Well, this is embarrassing.

holochain had a problem and crashed. To help us diagnose the problem you can send us a crash report.

We have generated a report file at “/tmp/report-f6c586ab-f108-44bf-b551-a5dc1fa5d9ff.toml”. Submit an issue or email with the subject of “holochain Crash Report” and include the report as an attachment.

We take privacy seriously, and do not perform any automated error collection. In order to improve the software, we rely on people to submit reports.

Thank you kindly!

But I cannot find the tmp folder? Like the new error message, that was something new at least! :slight_smile:

Cheers
D.

Can you post anything that was written above this? or was there nothing?